Garmin Forerunner 110 Blank Screen

I recently purchased a Garmin Forerunner 110 GPS watch to track my runs. I've been happy with it, but today when I plugged it into my computer after a run, the watch screen flashed "Saving activity" and then went blank. The watch was dead after that.

It had been fully charged before my run, so I was pretty sure it wasn't just out of juice. The instructions provided with the watch weren't helpful.

This blank-screen issue appears to be a common problem. The Forerunner 110 Blank Screen (Dead) thread in the Garmin forums has over 100 entries. You can browse that thread for details, but here is a summary of the suggested fixes:

  • Hold down the Light, Start/Stop, and Lap/Reset buttons for about 30 seconds. (This worked for me.)
  • Hold down all four buttons for about 7 seconds. (Didn't work for me.)
  • Hold down the Light button for about 6 seconds. (Didn't work for me.)
  • Hold down the "Power" button while plugging it into the computer. (My watch doesn't have a button labeled "Power". I tried this with the Light button, and with the Page/Menu button, but neither worked.)
  • Plug it into a different USB port. (Didn't work for me.)
  • Just leave it plugged in for a few days, and eventually it will spring back to life.
  • Rub the contacts with a pencil eraser.
  • Attach the USB clip, but don't attach the clip to a USB port, and hold the Light button for 6 seconds.
  • Check whether there is a firmware update available.
  • Try a master reset.
  • Contact Garmin Customer Support.
  • Take the watch back to where you bought it for replacement/refund.

After I got it working, i checked for a firmware update, and indeed there was a new firmware version available for the Forerunner 110. This is in the release notes:

Changes from version 2.60 to version 2.70:

Fixed an issue where the device could display a blank screen while connected to the charger.

I installed the update. I'll have to wait to see whether the problem recurs.

Update 2014-01-23: The screen went blank again. Hold down the Light, Start/Stop, and Lap/Reset buttons got it working.

Update 2014-03-09: Blank again, and the above remedies weren't working. The recharging display did appear when I connect it to USB, but it wouldn't do anything when disconnected. I let it sit disconnected for a few hours, and it sprung to life.